Contents
Overview........................................................................................................................................3
About COUNTER..........................................................................................................................3
Accessible Reports......................................................................................................................5
Authentication..............................................................................................................................7
Service Endpoint Address/URL and WSDL................................................................................8
Making Manual Requests to the SUSHI Web Server.................................................................9
Using SoapUI..................................................................................................................................9
Appendix A.....................................................................................................................................14
   Sample SOAP Request ............................................................................................................14
Appendix B.....................................................................................................................................16
   Sample SOAP Response........................................................................................................16
Appendix C.....................................................................................................................................18
   WSDL for Scholarly iQ SUSHI Web Service.............................................................................18
   Additional Resources..............................................................................................................19
Overview


In order to use this service, you must have a Web services client that can send and receive SOAP messages conforming to the SUSHI 1.6 standard. In addition, you must be provided access by Scholarly iQ, using a unique authorization key (Requestor ID).

About SUSHI


“The protocol was designed to be both generalized and extensible, meaning it could be used to retrieve a variety of usage reports. An extension designed specifically to work with COUNTER reports is provided with the standard, as these are expected to be the most frequently retrieved usage reports.”

“The standard is built on SOAP (Simple Object Access Protocol) for transferring request and response messages. The GetReport method is used for transferring ReportRequest as the input message and returning ReportResponse as the output message.”

“The standard includes a versioned Web Services Description Language (WSDL), to describe the Web service namespace and operations, and a generalized XML schema with the syntax of the SUSHI protocol. Rules for report naming are outlined and complemented by an external reports registry, which provides for the definition of both COUNTER and non-COUNTER reports.”

Source: SUSHI website – http://www.niso.org/workrooms/sushi

About COUNTER

“Launched in March 2002, COUNTER (Counting Online Usage of Networked Electronic Resources) is an international initiative serving librarians, publishers and intermediaries by setting standards that facilitate the recording and reporting of online usage statistics in a consistent, credible and compatible way. The first COUNTER Code of Practice, covering online journals and databases, was published in 2003. COUNTER’s coverage was extended further with the launch of the Code of Practice for online books and reference works in 2006. The body of COUNTER compliant usage statistics has steadily grown as more and more vendors have adopted the COUNTER Codes of Practice. This has contributed to the new discipline of usage bibliometrics and a great deal of work is underway to try to establish value metrics associated
with usage, in which the COUNTER compliant statistics play an increasingly important role.”
Source: COUNTER website – http://www.niso.org/workrooms/sushi/#counter

“NISO and COUNTER have signed a Memorandum of Understanding that assigns the responsibility for maintaining the XML schema version of COUNTER reports to NISO. This will ensure that the SUSHI and COUNTER schemas are always synchronized.”
Source: SUSHI website – http://www.niso.org/workrooms/sushi
## Accessible Reports

The following reports may be obtained via the Scholarly iQ SUSHI Web Service. These reports conform to the COUNTER Code of Practice Release 4.

<table>
<thead>
<tr>
<th>Report ID</th>
<th>Report Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BR1</td>
<td>Book Report 1</td>
<td>Number of Successful Title Requests by Month and Title</td>
</tr>
<tr>
<td>BR2</td>
<td>Book Report 2</td>
<td>Number of Successful Section Requests by Month and Title</td>
</tr>
<tr>
<td>BR3</td>
<td>Book Report 3</td>
<td>Access Denied to Content Items by Month, Title, and Category</td>
</tr>
<tr>
<td>BR4</td>
<td>Book Report 4</td>
<td>Access Denied to Content Items by Month, Platform, and Category</td>
</tr>
<tr>
<td>BR5</td>
<td>Book Report 5</td>
<td>Total Searches by Month and Title</td>
</tr>
<tr>
<td>CR1</td>
<td>Consortium Report 1</td>
<td>Number of Successful Full-text Journal Article or Book Chapter Requests by Month</td>
</tr>
<tr>
<td>CR2</td>
<td>Consortium Report 2</td>
<td>Total Searches by Month and Database</td>
</tr>
<tr>
<td>CR3</td>
<td>Consortium Report 3</td>
<td>Number of Successful Multimedia Full Content Unit Requests by Month and Collection</td>
</tr>
<tr>
<td>DB1</td>
<td>Database Report 1</td>
<td>Total Searches, Result Clicks, and Record Views by Month and Collection</td>
</tr>
<tr>
<td>DB2</td>
<td>Database Report 2</td>
<td>Access Denied by Month, Database, and Category</td>
</tr>
<tr>
<td>JR1</td>
<td>Journal Report 1</td>
<td>Number of Successful Full-Text Article Requests by Month and Journal</td>
</tr>
<tr>
<td>JR1 GOA</td>
<td>Journal Report 1 GOA</td>
<td>Number of Successful Gold Open Access Full-Text Article Requests by Month and Journal</td>
</tr>
<tr>
<td>JR1a</td>
<td>Journal Report 1a</td>
<td>Number of Successful Full-Text Article Requests from an Archive by Month and Journal</td>
</tr>
<tr>
<td>JR2</td>
<td>Journal Report 2</td>
<td>Access Denied to Full Text Articles by Month, Journal, and Category</td>
</tr>
<tr>
<td>JR3</td>
<td>Journal Report 3</td>
<td>Number of Successful Item Requests and Turnaways by Month, Journal, and Page-Type</td>
</tr>
<tr>
<td>JR3 mobile</td>
<td>Journal Report 3 Mobile</td>
<td>Number of Successful Item Requests by Month, Journal, and Page-Type for usage on a mobile device</td>
</tr>
<tr>
<td>JR4</td>
<td>Journal Report 4</td>
<td>Total Searches Run by Month and Collection</td>
</tr>
<tr>
<td>JR5</td>
<td>Journal Report 5</td>
<td>Number of Successful Full-Text Article Requests by Year-of-Publication (YOP) and Journal</td>
</tr>
<tr>
<td>MR1</td>
<td>Multimedia Report 1</td>
<td>Number of Successful Multimedia Full Content Unit Requests by Month and Collection</td>
</tr>
<tr>
<td>MR2</td>
<td>Multimedia Report 2</td>
<td>Number of Successful Multimedia Full Content Unit Requests by Month, Collection, and Item Type</td>
</tr>
<tr>
<td>PR1</td>
<td>Platform Report 1</td>
<td>Total Searches, Result Clicks, and Record Views by Month and Platform</td>
</tr>
<tr>
<td>-----</td>
<td>-------------------</td>
<td>---------------------------------------------------------------------</td>
</tr>
<tr>
<td>TR1</td>
<td>Title Report 1</td>
<td>Number of Successful Requests for Journal Full-Text Articles and Book Sections by Month and Title</td>
</tr>
<tr>
<td>TR1 mobile</td>
<td>Title Report 1 Mobile</td>
<td>Number of Successful Requests for Journal Full-Text Articles and Book Sections by Month and Title (formatted for normal browsers/delivered to mobile devices AND formatted for mobile devices/delivered to mobile devices)</td>
</tr>
<tr>
<td>TR2</td>
<td>Title Report 2</td>
<td>Access Denied to Full-Text Items by Month, Title, and Category</td>
</tr>
<tr>
<td>TR3</td>
<td>Title Report 3</td>
<td>Number of Successful Item Requests by Month, Title, and Page-Type</td>
</tr>
<tr>
<td>TR3 mobile</td>
<td>Title Report 3 Mobile</td>
<td>Number of Successful Item Requests by Month, Title, and Page-Type (formatted for normal browsers/delivered to mobile devices and for mobile devices/delivered to mobile devices)</td>
</tr>
</tbody>
</table>

**Source:** SUSHI Website: [http://www.niso.org/workrooms/sushi/reports/](http://www.niso.org/workrooms/sushi/reports/)
Authentication

The Scholarly iQ SUSHI Web Service requires two levels of validation to successfully connect to the Web service and process reports.

Two credentials are required: an Authorization Key which is a 32-digit alpha-numeric string that will act as the Requestor ID, and a CustomerReference ID, which is a 2-10 digit alphanumeric string. These credentials are issued to clients via email from Scholarly iQ. If you did not receive this email or if you have questions about your account, please send an email message to Scholarly iQ SUSHI Support at sushi@scholarlyiq.com.
Service Endpoint Address/URL and WSDL

The Web service endpoint address for the Scholarly iQ SUSHI Web Service is:

http://sushi4.scholarlyiq.com/sushiservice.svc

The WSDL may be retrieved from:


For your convenience, the WSDL is printed in this guide (Appendix C).
Making Manual Requests to the SUSHI Web Server

Making a call to the Scholarly iQ SUSHI Web service manually will require the following:

- A third party tool that is capable of making SOAP calls such as SoapUI.
  - SoapUI (http://www.soapui.org/)
- The SUSHI WSDL endpoint.
- An authentication key and Customer Reference ID provided by Scholarly iQ to access the SUSHI Web service

Using SoapUI

Download SoapUI. You only need the “free” version which should work on any operating system that has Java installed. If you are operating behind a proxy service, you will need to tell SoapUI by going to File → Preferences → Proxy Settings and entering the required information.

Start the program. Click on File → “New SOAP Project.” Give the project a name. For example, if you want to request a JR1 report, you may want to call the project “SUSHI_JR1”. In this tutorial, it will be called “SUSHI_JR1.” For “Initial Wsdl” use the following Url:

Since the WSDL provides enough information to fully describe the service, a sample soap request will be automatically generated for you by SoapUI. Once you press “OK”, a project will be created on the left in the “Navigator” window.
Expand SUSHI_JR1 → BasicHttpBinding_ISushiService → GetReport. Double-click on “Request 1.” A window should appear that contains two sub windows. The one on the left is the SOAP request while the one on the right is the response. In the left window, the project generated a template SOAP request.
To get the request to work with the Scholarly iQ SUSHI web service, you’ll need to replace some of the question marks (“?”) with relevant data.

At the very least, the following elements should be filled in:

- The ID in the Requestor element should have the unique identifier (GUID) that was supplied to you by Scholarly iQ. Note that this field is “case” sensitive and all the alphabetic characters should be in UPPERCASE.
- The ID in the “CustomerReference” element will be the Customer Reference ID that was issued to you by email from Scholarly iQ.
- The Name attribute in "ReportDefinition" must reference a valid counter report. See table above for supported Report Types. When requesting a report for a Consortium account, please add a "c" to the end of the report type such as (JR1c).
- The Release attribute in ReportDefinition must be a valid release for the specified counter report. Specify a “4” for this question mark.
- The Begin and End elements of “UsageDateRange” must have a valid date range of the form YYYY-MM-DD. Statistics for a given month typically become available within the first two weeks of the subsequent month.
After filling in the values, press the “play” button on the upper left corner of the request window. After a few seconds, you should receive the response in the right response window. Although home-grown clients are necessary to produce the information, SoapUI is a great tool to supply the XML output which can then be imported into another system for processing.
Appendix A

Sample SOAP Request

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:coun="http://www.niso.org/schemas/sushi/counter"
xmlns:sus="http://www.niso.org/schemas/sushi">
  <soapenv:Header/>
  <soapenv:Body>
    <coun:ReportRequest ID="A000000-AAAA-00AA-AAAA-AA0A000000AA" Created="2014-03-06T02:03:29">
      <sus:Requestor>
        <sus:ID>A000000-AAAA-00AA-AAAA-AA0A000000AA</sus:ID>
        <sus:Name>Scholarly iQ</sus:Name>
        <sus:Email>sushi@scholarlyiq.com</sus:Email>
      </sus:Requestor>
      <sus:CustomerReference>
        <sus:ID>Site/InstitutionID</sus:ID>
        <sus:Name>Scholarly iQ</sus:Name>
      </sus:CustomerReference>
      <sus:ReportDefinition Release="4" Name="JR1">
        <sus:Filters>
          <sus:UsageDateRange>
            <sus:Begin>2013-12-01</sus:Begin>
            <sus:End>2013-12-31</sus:End>
          </sus:UsageDateRange>
        </sus:Filters>
      </sus:ReportDefinition>
    </coun:ReportRequest>
  </soapenv:Body>
</soapenv:Envelope>

Notes:

- The ID attribute in the <Requestor> element should have the unique identifier (GUID) that was supplied to you by Scholarly iQ.

- The Name and Email attributes in the <Requestor> element will automatically be replaced by the Name and Email attributes in the SOAP Response with data from your account. These attributes in the requestor element may be left blank.

- The ID attribute in the <CustomerReference> element should have the Site/Institution ID that was supplied to you by Scholarly iQ or the Consortium Member ID.
- The Name field in the `<CustomerReference>` element is an optional field and may be customized by the client (e.g. Client Name).

- The `<ReportDefinition>` Name field should have the name of the report that the client would like to process. See above table for list of Report Types. Note that some reports may not be supported for certain accounts. The report types that are available for the client’s account can be obtained from Scholarly iQ. When requesting a report for a Consortium, please add a “c” to the end of the report type such as (JR1c).

- The Release attribute in `<ReportDefinition>` must be a valid release number for the specified counter report. Specify a “4” for this attribute.

- The Begin and End fields of `<UsageDateRange>` must have a valid date range of the form YYYY-MM-DD. Statistics for a given month typically become available within the first two weeks of the subsequent month.
Appendix B

Sample SOAP Response

```xml
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
    <rr:ReportResponse ID="A0000000-AA00-00AA-A000-AA0A000000AA" Created="2014-03-06T02:03:29" xmlns:rr="http://www.niso.org/schemas/sushi/counter">
      <s:Requestor xmlns:s="http://www.niso.org/schemas/sushi">
      </s:Requestor>
      <s:CustomerReference xmlns:s="http://www.niso.org/schemas/sushi">
      </s:CustomerReference>
      <s:ReportDefinition Release="4" Name="JR1" xmlns="http://www.niso.org/schemas/sushi">
      </s:ReportDefinition>
      <rr:Report>
        <Report Name="JR1" Version="4" Created="2014-03-06T02:03:41" ID="JR1">
      </rr:Report>
    </rr:ReportResponse>
  </s:Body>
</s:Envelope>
```
<Value>1559-128X</Value>
</ItemIdentifier>
<ItemIdentifier>
<Type>Online_ISSN</Type>
<Value>2155-3165</Value>
</ItemIdentifier>
<ItemIdentifier>
<Type>DOI</Type>
<Value>10.1364/ao.</Value>
</ItemIdentifier>
<ItemIdentifier>
<Type>Proprietary</Type>
<Value>AO</Value>
</ItemIdentifier>
<ItemPlatform>Optics InfoBase</ItemPlatform>
<ItemPublisher>Optical Society of America</ItemPublisher>
<ItemName>Applied Optics</ItemName>
<ItemDataType>Journal</ItemDataType>
<ItemPerformance>
<Period>
<Begin>2013-12-01</Begin>
<End>2013-12-31</End>
</Period>
<Category>Requests</Category>
<Instance>
<MetricType>ft_html</MetricType>
<Count>11</Count>
</Instance>
<Instance>
<MetricType>ft_pdf</MetricType>
<Count>2</Count>
</Instance>
<Instance>
<MetricType>ft_total</MetricType>
<Count>13</Count>
</Instance>
</ItemPerformance>
</ReportItems>
</Customer>
</Report>
</rr:ReportResponse>
</s:Body>
</s:Envelope>
Appendix C

WSDL for Scholarly iQ SUSHI Web Service

```xml
<wsdl:definitions name="SushiService" targetNamespace="http://tempuri.org/"
xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/
xmlns:wsa10="http://www.w3.org/2005/08/addressing"
xmlns:tns="http://tempuri.org/
xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/
xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"
xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/08/policy"
xmlns:wsam="http://www.w3.org/2007/05/addressing/metadata"
xmlns:wsaw="http://www.w3.org/2006/05/addressing/wsdl"
xmlns:i0="SushiService"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"

<wsdl:import namespace="SushiService"
location="http://sushi4.scholarlyiq.com/SushiService.svc?wsdl=wsdl0"/>

<wsdl:types/>
<wsdl:binding name="BasicHttpBinding_ISushiService" type="i0:ISushiService">
  <soap:binding transport="http://schemas.xmlsoap.org/soap/http"/>
  <wsdl:operation name="GetReport">
    <soap:operation soapAction="SushiService:GetReportIn" style="document"/>
    <wsdl:input name="GetReportRequest">
      <soap:body use="literal"/>
    </wsdl:input>
    <wsdl:output name="GetReportResponse">
      <soap:body use="literal"/>
    </wsdl:output>
  </wsdl:operation>
</wsdl:binding>
<wsdl:service name="SushiService">
  <wsdl:port name="BasicHttpBinding_ISushiService" binding="tns:BasicHttpBinding_ISushiService">
    <soap:address location="http://sushi4.scholarlyiq.com/SushiService.svc"/>
  </wsdl:port>
</wsdl:service>
</wsdl:definitions>
```
Additional Resources
NISO’s SUSHI Workroom: http://www.niso.org/workrooms/sushi
SoapUI Testing Tool: http://www.soapui.org/